No vapour is being produced by my device

Below you'll find the most common remedies for devices that are not producing any vapour:

If the battery appears to be working fine (ie if the button lights up as expected when pressed), then it is possible some liquid has gone down the central part of your clearomizer/tank or the coil has been flooded (usually by drawing/sucking too hard). If you think this could be the case, please try the following: unscrew the clearomizer/tank, place a tissue where the battery was and blow into the mouthpiece a couple of times. If there was any e-liquid in the centre pipe or if there's an excess of liquid inside the coil head, this should remove most of it. Now screw it back on and try it again.

If you're getting not hit at all and your device isn't producing any vapour, here are some troubleshooting tips:

If possible, detach the tank/pod/clearomizer and ensure there is no residue where the battery connects to the tank. If there is a little bit of liquid or dust, this can block the electrical current. These connections often look silver or gold in appearance and can be found at the top end of the battery. 

another issue which can cause a connection problem with the battery is the over-tightening of the battery with the clearomizer/tank. If you try the above and it does not work, try loosening the connection between clearomizer/tank and battery slightly.

If your device is producing vapour but the hit isn't as strong, you likely need to charge your device. In most vape kits, the power output will slowly decrease as the battery life does, leading to less vapour and less of a hit. 



Submit a ticket

Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.